Follow

What are Assguard system requirements?

Currently, Assguard works on:

iOS 11.0 and higher
Android 6.0 and higher
Windows 10

Was this article helpful?
2 out of 4 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.